logo

Notification

Icon
Error

Options
Go to last post Go to first unread
Offline Ravil Nugmanov  
#1 Posted : Tuesday, March 24, 2015 8:56:18 AM(UTC)
Ravil Nugmanov

Rank: Newbie

Joined: 3/24/2015(UTC)
Posts: 2

Hello,
I tried to download and use the SDK for Windows. The sample application project compiles fine if Visual Studio 2008 toolset is used for compilation. But when I try to compile that project for 2013 or 2012 toolset, I get unresolved link errors.

As newer versions of VS has support for nice features of C++11, like lambda functions, concurrency library etc, it would be very sad to have limitation for the applications using the UA Client SDK to compile only under 2008 toolset.

So, the question is, is it just me doing something wrong, or it is really limitation of the SDK to compile code using it with 2008 toolset.

Thank you, Ravil

Edited by user Tuesday, March 24, 2015 8:58:17 AM(UTC)  | Reason: Not specified

Offline Patrick Griffiths  
#2 Posted : Tuesday, March 24, 2015 9:12:42 AM(UTC)
Patrick Griffiths

Rank: Advanced Member

Joined: 11/28/2014(UTC)
Posts: 37

Was thanked: 4 time(s) in 4 post(s)
Hi Ravil,

You are correct. The current release supports VS 2008 on Windows. Upcoming releases will add to the set of supported compilers and configurations, as well as the supported Linux distributions.

Thanks for your interest and stay tuned!

Patrick
Offline Ravil Nugmanov  
#3 Posted : Tuesday, March 24, 2015 11:54:08 AM(UTC)
Ravil Nugmanov

Rank: Newbie

Joined: 3/24/2015(UTC)
Posts: 2

Hi Patrick,

So you will include into the release binaries for 2010, 1012, 2013, and then eventually for 2015, right?
I wonder when the release build for VS 2012 is scheduled?

Or you might have plans to make API de-coupled, so the single set of binaries binaries (built on 2008 compiler or whatever, does not matter) will become just compatible with all versions from side of the application using the SDK?

Thank you, Ravil
Offline Patrick Griffiths  
#4 Posted : Tuesday, March 24, 2015 11:59:22 AM(UTC)
Patrick Griffiths

Rank: Advanced Member

Joined: 11/28/2014(UTC)
Posts: 37

Was thanked: 4 time(s) in 4 post(s)
Ravil,

I'm sure you understand that I can't comment on specifics. Upcoming releases will add to the set of supported compilers and configurations, as well as the supported Linux distributions.

Thanks for your interest,
Patrick
Offline martin  
#5 Posted : Wednesday, October 28, 2015 6:08:27 AM(UTC)
martin

Rank: Newbie

Joined: 6/5/2015(UTC)
Posts: 2

Hi Patrick,

How about the new releases? Could it support VS2012 now?
In the OPCUA client SDK manual, it sounds that the SDK could support higher version like VS2012.
"Software Requirements
To correctly build and run samples on Windows OS, the following is required:
# Microsoft Visual Studio 2008 or higher"

I have tried to compile with VS2012 recently, but still get some errors about unresolved LINK error.

Thanks.
Martin

**************************

************************************
Offline Patrick Griffiths  
#6 Posted : Thursday, October 29, 2015 7:40:11 AM(UTC)
Patrick Griffiths

Rank: Advanced Member

Joined: 11/28/2014(UTC)
Posts: 37

Was thanked: 4 time(s) in 4 post(s)
Martin,

The latest release support VS2012 and VS2013, 32 and 64 bit for both. We dropped VS2008.

Patrick
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.