logo

Notification

Icon
Error

Options
Go to last post Go to first unread
Offline Vladimir Gonchar  
#1 Posted : Monday, December 1, 2014 10:23:26 AM(UTC)
Vladimir Gonchar

Rank: Member

Joined: 12/1/2014(UTC)
Posts: 19

Thanks: 2 times
Was thanked: 2 time(s) in 2 post(s)
Hello,
I got an Ubuntu-14.04-x86-Linux_UA_Client_SDK (beta not released). Trying to use it on VM Centos7 , Eclipse Luna. My OPC Servers are Kepware on my real PC and Matricon Embeded OPC.

Create "my first project" conform documentation provided with SDK. (simple client connect to server and get some data).
I can connect to the server. But as soon as I create a session(uaSession1->Connect(*status)), handler return me session state: Just Created and nothing happens.

This is a callback handlers messages:

Start
Endpoint Status 0
Server Connection Status Changed To: State_Connected
Session configuration complete result : 0
Session State Changed: Activating on server0
Session State Changed: Just Created0


But the most interesting situation is - if I run 10-20 times in a row, project session finally creates.
This is a callback handlers messages:

Start
Endpoint Status 0
Connection created 0
Server Connection Status Changed To: State_Connected
Session configuration complete result : 0
Session State Changed: Activating on server0
Session State Changed: Just Created0
Session State Changed: Creating on server0
Session State Changed: Created on Server0
Session Request Complete with response: CreateSession
Session State Changed: Activating on server0
Session State Changed: Activated on server0
Session Request Complete with response: ActivateSession


That happens with both OPC UA Servers.
Could you please help me to find why that happens?

Thank you.

Edited by user Monday, December 1, 2014 10:29:44 AM(UTC)  | Reason: spelling

Offline Patrick Griffiths  
#2 Posted : Monday, December 1, 2014 3:26:07 PM(UTC)
Patrick Griffiths

Rank: Advanced Member

Joined: 11/28/2014(UTC)
Posts: 37

Was thanked: 13 time(s) in 11 post(s)
Hi Vladimir,

Are you running your client on Centos7? If so, we unfortunately don't support it yet. Ubuntu 14.04 is the distribution you want. That said, it sounds like you're able to build and run your code so it's probably not the main issue.

If your code is short enough to fit in a forum post, please post it and I'll see what can do. Otherwise, I've asked the IT powers to allow file attachments, so when that is enabled you could attach a zip file of your code and I'll have a look.

Patrick

Edited by user Monday, December 1, 2014 11:42:42 PM(UTC)  | Reason: Corrected missing 'not'

Offline Vladimir Gonchar  
#3 Posted : Tuesday, December 2, 2014 8:41:07 AM(UTC)
Vladimir Gonchar

Rank: Member

Joined: 12/1/2014(UTC)
Posts: 19

Thanks: 2 times
Was thanked: 2 time(s) in 2 post(s)
Hi Patrick,
Here is some information from "MatriconOPC UA Client SDK Release Notes.txt":
......
Here are the system requirements to install and use this SDK with.
Linux Operating Systems:
# Red Hat Enterprise Linux OS (Cent OS) 7.x or higher (32 bit)
# Ubuntu Linux 14.04 LTS or higher (32 bit)
........


As you see this client must work on Centos and it is working! (I spent 3 weeks just to make it work under Centos7....)

This is not a system issue. May be I made a buggy connect/session configuration. But I can sometimes create a session...

I can not post my source code. It's 400 lines. Will be nice if I can attach ZIP or I can send it direct to your email.

Thank you.


Update. Eclipse Luna was updated to Eclipse Mars.
Project also was compiled on Qt 5.3.2(32 bit).
Results remain the same.

Edited by user Tuesday, December 2, 2014 10:15:04 AM(UTC)  | Reason: more information

Offline Patrick Griffiths  
#4 Posted : Tuesday, December 2, 2014 9:56:34 AM(UTC)
Patrick Griffiths

Rank: Advanced Member

Joined: 11/28/2014(UTC)
Posts: 37

Was thanked: 13 time(s) in 11 post(s)
Hi Vladimir, I apologies, but those release notes are not correct (believe me - I'm one of the SDK developers). It seems you've got it to run so let's not get hung up on that for the moment; however, you should be preparing to move to Ubuntu 14.04. Subsequent releases may not run on CentOS 7. We are planning to support other Linux distributions, but I can't make any promises about when that will land or which distributions will be supported.

You can send your code to me using the email address in my forum profile.

Patrick


Offline Vladimir Gonchar  
#5 Posted : Tuesday, December 2, 2014 10:33:18 AM(UTC)
Vladimir Gonchar

Rank: Member

Joined: 12/1/2014(UTC)
Posts: 19

Thanks: 2 times
Was thanked: 2 time(s) in 2 post(s)
It's very very sad to hear after more than a month of fight... :(

We absolutely disappointed in Ubuntu. We can not use it on the critical devices.

Could you please tell if this release strictly Ubuntu related or we can use it on Debian?

Thank you.


PS. Can not access you profile. Click on your picture redirect me on forum main page... (IE & Chrome)
Could you please email me vgonchar %$ millenstim.ca

Thank you.

Edited by user Tuesday, December 2, 2014 10:41:25 AM(UTC)  | Reason: forum profile preview bug

Offline Patrick Griffiths  
#6 Posted : Tuesday, December 2, 2014 11:30:39 AM(UTC)
Patrick Griffiths

Rank: Advanced Member

Joined: 11/28/2014(UTC)
Posts: 37

Was thanked: 13 time(s) in 11 post(s)
Vladimir,

We currently build our linux binaries on Ubuntu against a number of distribution provided libraries that will change depending on the specific distribution. To be completely honest, we just don't currently have the infrastructure in-place to build binaries for a large number of Linux distribution. If you can satisfy the SDK's shared object dependencies on Debian, it will run. But we can't guarantee anything but the distribution we build for. If you're really stuck, I suggest you take-up the issue with product manager: Darek Kominek. I believe you've been in contact with him previously.

Go ahead and email me your code at patrick dot griffiths at honeywell dot com.

Offline Patrick Griffiths  
#7 Posted : Wednesday, December 10, 2014 12:45:36 PM(UTC)
Patrick Griffiths

Rank: Advanced Member

Joined: 11/28/2014(UTC)
Posts: 37

Was thanked: 13 time(s) in 11 post(s)
Ok, we got Vladimir started once I looked at his code.
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Matrikon Subscribe  |   Matrikon Unsubscribe  |   Global Unsubscribe  |   Privacy Statement  |   Do Not Sell My Personal Information   |   Cookie Notice